Уведомление посетителя сайта о его устаревшем браузере

02/02/2017  веб-разработка

Некоторые посетители вашего сайта могут пользоваться устаревшим браузером. Это — проблема, так как ваш современный интернет-магазин или корпоративный сайт в старых браузерах будет выглядеть совсем не таким, каким видите его вы. Структура страницы может рассыпаться, красивые шрифты и эффекты не появятся, а некоторые скрипты и вовсе не позволят открыться сайту.

Чтобы предупредить посетителя о том, что его браузер не поддерживает функционал сайта, вы можете настроить уведомление с помощью скрипта. Панелька с уведомлением прилипает сверху. После нажатия на панель скрипт предложит список актуальных версий современных браузеров для скачивания.

Минимальные требования для браузеров и вид уведомления можно установить по умолчанию в конструкторе или настроить самостоятельно в скриптах.

Яндекс конструктор обновления браузеров

https://tech.yandex.ru/browser/constructor/

Укажите минимальные требования к 12 браузерам, настройте цвет уведомления. Скопируйте полученный код и вставьте его на каждой странице вашего сайта перед закрывающим тегом </body>. Работа скрипта на стороне сервиса.

Яндекс.Конструктор обновления браузеров

Browser-Update.org

https://browser-update.org/ru/

Укажите минимальные требования к 5 браузерам. Отключите/включите уведомления об уязвимостях в системе безопасности браузера. Кроме того, отключите/включите уведомления для браузеров, которые не поддерживаются разработчиками. Отключите/включите уведомления для мобильных браузеров. Есть готовые плагины для CMS. Работа скрипта на стороне сервиса.

Browser-Update Конструктор обновления браузеров
Михаил Апсолямов
Михаил Апсолямов Создаю сайты. Оказываю услуги seo-продвижения. Провожу аудиты сайтов. Пишу статьи на заказ. Услуги и цены.

 

наверх